Support Article
BIX Extract takes long to process the record
SA-98522
Summary
Business Intelligence Exchange (BIX) Extract performance degrades from the Command Line when processing a record.
Error Messages
Not Applicable
Steps to Reproduce
- Upgrade Pega 7 Platform to Pega Platform 8.2.1.
- Perform an XML extract through the BIX.
Root Cause
A defect or configuration issue in the operating environment.
Resolution
Make the following change to the operating environment:
As part of the Command Line BIX Extract script, add the below node settings,
-DNodeType=BIX -DNodeSettings="Pega-IntegrationEngine/disableEpochDateTime=false;Pega-IntegrationEngine/disableEpochDate=false;Pega-RulesEngine/EnableAttributeBasedSecurity=false"
Published February 10, 2020 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.