Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX Job is taking much longer time

SA-8605

Summary



Slowness observed during BIX extraction.

Error Messages



Not Applicable.

Steps to Reproduce



Run the BIX extract daily, slowness observed when DB records are increasing over period.


Root Cause



The root cause of this problem is defect/misconfiguration in the operating environment. 
Analyzed three days extraction data for Elapsed Time, Instances per second , Total Records. The increase in the number of records in the database causes the slowness. 


RESOLUTION

This issue is resolved through the following local-change: 
To improve performance, increase number of records would increase the SQL query execution time:
  • Use incremental BIX extracts rather than extracting the entire set of records every time, this reduces the amount of load on the server.
  • Add indexes to WO table as to COUNT the records in DB is taking >5 minutes.
  • Use Purge/Archive wizard to archive the records which are not required in DB.

Published June 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us