Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX separates data with default delimiter of CSV file changed

SA-38190

Summary



Delimiter changed for CSV generated by BIX but still its separates the data into two columns because of comma "," in the data .
Update the bix.xml with -l parameter in bix.xml to change the default delimiter to some other character like "|".

But still user is getting separated data in columns whenever the comma "," is present in the data.

Excepted : Data should not be separated in some other columns whenever comma "," is present in data. It should be in single column itself as there is change in the default delimiter for CSV file.


Error Messages



Not Applicable


Steps to Reproduce



1. Do the configurations as per the instructions guidelines for BIX to run from command line prompt in system.
2. Change the delimiter in bix.xml , used the -l parameter in bix.xml and specify the character to be used instead of a comma.


Root Cause



Excel is treating ',' as a delimiter when file extension is .csv which cannot be modified and which is the purpose of csv file.

Resolution


Following items are recommended by Pega:

  • Use xml extract if your requirement is not satisfied using csv extract.
  • After extracting to csv, make the file extension to .txt and open with Excel, then Excel will guide to give own delimiter(text import wizard).
Suggest Edit

Published July 20, 2017 - Updated December 2, 2021

Did you find this content helpful? Yes No

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us