Support Article
Black screen appears on iOS when app is first installed
SA-38080
Summary
The user upgraded from 7.1.8 to 7.2.2. They have installed their Mobile application on iOS devices and while launching the application they are seeing a black screen which appears for 5-6 seconds before the login screen shows up. They reported this issue to be specific to iOS devices.
Error Messages
Not Applicable
Steps to Reproduce
- Scan the QR code of the mobile application using the Pega Mobile Express application.
- Proceed to download and install the mobile application on the iOS device.
- Launch the installed application on an iOS device like iPhone or iPad.
- The screen goes blank for 5-6 seconds after which the branding icon is displayed on the whole screen.
Root Cause
A defect in Pegasystems’ code or rules is identified as root cause of the issue. If we create custom application install splash screen without pega logo element then animateOnLoadScreen function fails which results in splash screen never being hidden.
Resolution
Follow the below steps:
- Apply HFix-34176.
- Delete the Pega Temp Directory, extract marker file and restart the application server.
- Delete the previously installed mobile application from the iOS device.
- Ensure that all the branding assets used for building the mobile application are in place.
- Rebuild the mobile application after enabling splash screen (set in custom.properties present in assets.zip file).
container.splashScreenEnabled=true - Install the updated mobile application on the iOS device.
Published May 16, 2017 - Updated October 8, 2020
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