Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Blank screen after login after upgrading from 6.3SP1 to 7.1.7

SA-7275

Summary



You have upgraded a Pega 6.3 SP1 to  7.1.7 single schema on Oracle 11.2 database. The system starts up and you receive the login page but once you login you see a blank Screen/UI and see errors in the log file that indicate "Failed to resolve rule file". The rule file varies depending on the content source. There is a startup parameter setup for: -Dpega.tmpdir

Error Messages



ERROR - Unable to obtain DataSource for hmdatamart; javax.naming.NameNotFoundException: java:jdbc/HMDataMart

ERROR - 404 on request: /ibl3mvrXbCEwRU1e06LM_a5jj-LzX6Z9*/Failed to resolve rule file:

Examples include:
Rule-File-Binary.webwb.report_excel.gif
Rule-File-Text.webwb.pega_desktop_domainsuffix.js!
Rule-File-Binary.webwb.pxmenu_button_arrow_white.png;


Steps to Reproduce



Log into application

Root Cause



The root cause of this issue was a problem with the upgrade.  It did not complete successfully.

Resolution



This issue is resolved through the following local change: Re-run the upgrade in this environment.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us