Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Borders do not appear for read-only text in skin

SA-7425

Summary



Borders do not appear for read-only text in skin. 

Error Messages



Not applicable.

Steps to Reproduce



1. Add a new Mixin on Skin of type combination to declare text and border.
2. Add border as soild.
2. Notice that for read only of type "Text Inputs & Formatted Text" on "Components" tab is not working for readonly fileds.


Root Cause



pyEndUserSkin71 does not intake the value entered of borders for read only text.


Resolution



This issue is resolved through the following Local-change:

1. Create a CSS ReadOnlyBorder in pyEndUser71 skin.
2. Apply the below code in the css(based on required color)


.dataValueRead .standard{
border:1px solid pink !important;
}
 


3. Test by setting the 'Edit Option' as read-only (always) and notice that the border appears.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us