Support Article
Bulk Process List View does not show expected data (rows)
SA-291
Summary
Business User does not see the expected assignments (or records) on Bulk Process list view inside Case Manager portal.
Error Messages
No error message,
'No matching data was found' message displayed
Steps to Reproduce
1. In Case Manger portal, launch Bulk Process screen (Options menu --> Bulk Actions)
2. In Bulk Process screen, select an Operator ID from ‘Transfer work from’ drop down
3. New Tab opens with the list view, but list view does not display any records (rows). It displays the message 'No matching data was found'
Root Cause
The root cause of this problem is a defect in custom application code/rules. The issue is occuring due to lack of required "PerformBulk" privilege on the Access Role record (RULE-ACCESS-ROLE-NAME) defined on the User's Access Group.
RULE-ACCESS-ROLE-OBJ record SR-Work-POC

In above record, there is NO privilege to perform bulk processing. In Out of the Box (OOTB) record, you will see the privilege as expected. See below snap shots
Notice that, ‘PerformBulk’ privilege exists for RULE-ACCESS-ROLE-OBJ record PegaSample-CustomerRequest

Resolution
This issue is resolved through the following local change:
Make sure that you have defined the Privilege 'PerformBulk' for RULE-ACCESS-ROLE-OBJ rule defined for your Work class, set Level to 5.
Published March 10, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.