Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Bulkprocessing email configuration

SA-5518

Summary



User reported that in Bulkprocessing they are not able to send an email on transfering a work item from one operator to another.

Error Messages



you are not authenticated to send an email.


Steps to Reproduce



1.Go to bulk processing tab,select an operator and work type and operation to perform
2.on selection a work list will be displayed
3.select a work item to transfer an assignment to another operator
4.on selection of run in back ground we are getting a pop up message saying that "we are unable to send an email"


Root Cause



The root cause of this problem is a defect in customer application code/rules. 
A Default Email account was created in the application and it was expected that PRPC would pick the default account if no Email account was found in the current workpool. However, we were unable to receive emails (post bulk processing) even though our email settings were all fine. 
Tracer logs showed that the default Email account was indeed getting picked up.
When background processing by the Pega-ProCom agent is complete, the agent sends an email message listing the count of assignments selected and processed, and a list of the keys of assignments not processed. The Agent was restarted but the problem persisted. 

It is noted that Bulk processing may be unable to complete assignments for various reasons, including the inability to acquire a lock. It was suspected that the assignments were themselves were not getting completed. We can check this by navigating to:  Pega Button > Process & Rules > Tools > Work Admin > Worklist Assignment Errors to research these issues. Customer reported that there were indeed assignment with "Error: status".

Resolution



This issue is resolved through the following local change:

It is noted that Bulk processing may be unable to complete assignments for various reasons, including the inability to acquire a lock. It was suspected that the assignments were themselves were not getting completed. We can check this by navigating to:  Pega Button > Process & Rules > Tools > Work Admin > Worklist Assignment Errors to research these issues. Customer reported that there were indeed assignment with "Error: status". Resolving these issues solved the problem. 
It was also recommended that we create an email account in the current workppool. 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us