Support Article

Busy indicator displays on case refresh with required properties

SA-66691

Summary



Busy indicator displays continuously on refreshing a case containing required properties which are validated by the application. This occurs in the Chrome browser.


Error Messages



JavaScript error in the console:

pzpega_ui_harness_deferred_ts_1342430166!!.js:1969 Uncaught TypeError: Cannot read property 'stopPropagation' of undefined 
at Object.stopPropagation (pzpega_ui_harnesscontext_13405383939!pzevalharnessjson_13618607379.js!pzpega_ui_lib_provider_1191955478!pega_yui_12813728239!desktopwrapper_12681084965!!.js:3133)
at Object.stopEvent (pzpega_ui_harnesscontext_13405383939!pzevalharnessjson_13618607379.js!pzpega_ui_lib_provider_1191955478!pega_yui_12813728239!desktopwrapper_12681084965!!.js:3122)
at pega.ui.Doc.areInputsValid (pega_ui_harness_13366281749!pzpega_ui_harness_actions_11967870250!!.js:2009) 
at pega.ui.Doc.submitWrapper (pzpega_ui_harness_deferred_before_11691697527!!.js:12895) 
at pega.ui.Doc.submit (pzpega_ui_harness_deferred_before_11691697527!!.js:12833) 
at doFormSubmit (pega_ui_harness_13366281749!pzpega_ui_harness_actions_11967870250!!.js:13572) 
at pega.ui.Doc.submitWhenFail (pzpega_ui_harness_deferred_before_11691697527!!.js:12361) 
at pega.control.Actions.refresh (pega_ui_harness_13366281749!pzpega_ui_harness_actions_11967870250!!.js:37881) 
at executeAction (pzpega_ui_harness_deferred_ts_1342430166!!.js:1767) 
at executeOne (pzpega_ui_harness_deferred_ts_1342430166!!.js:1963
)


Steps to Reproduce

  1. Design a case with required properties that display on the screen for the user to enter values.
  2. Open the Case Default portal.
  3. Create a new case.
  4. Navigate to the section with required properties.
  5. Navigate to the Actions menu to refresh the case. Error message displays. After acknowledging the error, the busy indicator displays continuously.


Root Cause



A defect in Pegasystems’ code  or rules.


Resolution



Apply HFix-47836.


 

Published October 17, 2018 — Updated January 11, 2019


Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.