Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Busy indicator does not hide modal dialog completely



When a busy indicator appears on a modal dialog (on slow connections) it does not hide the entire modal dialog. As a result user can edit or submit the modal even when not allowed to.

Error Messages


Steps to Reproduce

1) Create a lengthy modal dialog section
2) Launch the modal over a slow connection.
3) Press Submit and notice how certain fields can be still edited.

Root Cause

A defect in Pegasystems’ code or rules causes the issue. 


This issue is addressed as part of the platform in Pega 7.2.1. Users can perform the following local-change to address the issue in the interim:

1. Save UserWorkForm to your application ruleset
2. Copy and paste the code below to the UserWorkForm and save.

<!-- Local change for setting busy indicator mask correctly on modal windows  -->
  .pega_ui_masking {
  position: fixed;
  background: transparent url(pybusy_ind_mask_img.png) repeat;
  top: 0;
  left: 0;
  right: 0;
  bottom: 0;
  height: auto !important;
  width: auto !important;



Suggest Edit

Published May 4, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us