Support Article
Call to SOAP Service fails with PRPC 6.3 SP1
SA-18837
Summary
User had PRPC 6 system interacting with a web service (provider enclarity) over SOAP protocol.
User has imported signer certificates for enclarity server and also those for signing certificate authority (CA) to client's standard truststore of cacerts.
Following the import, when Pega connector tries to communicate with enclarity service, the SOAP call to the service fails.
Error Messages
Unable to find Data-Admin-Security-WSSecurityProfile while trying to access a SSL endpoint without WS-Security Profile configured.
Steps to Reproduce
Invoke SOAP service from User portal.
Root Cause
A defect or configuration issue in the operating environment WS-Security was not enabled for the Connect-SOAP rule and Security profile was not configured too.
Resolution
User has to configure WS-Security by configuring the Security profile rule with appropriate 'Signature' algorithm for the signer certificates and must apply appropriate values for keystores or trustores.
Published January 30, 2016 - Updated October 8, 2020
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