Support Article
Campaign Restart option does not work post upgrade
Summary
User is on Pega Platform 8.3 and has Pega Marketing 8.3 on top of it.
Post upgrading to Pega Marketing 8.3, the campaign Restart option does not work.
Error Messages
(egamkt_engine_pegamktutilities) ERROR - PegaMKTUtilities.createEmptyExclusionView - Exception creating empty exclusion view with DDL:
CREATE OR REPLACE VIEW MKTEXCLUDEPR2415 AS SELECT CustomerID FROM MCCMEXTMKTINT.Customer WHERE 1=2
java.sql.SQLSyntaxErrorException: ORA-00904: "CUSTOMERID": invalid identifier
at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:494) ~[ojdbc8.jar:12.2.0.1.0]
at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:446) ~[ojdbc8.jar:12.2.0.1.0]
at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1054) ~[ojdbc8.jar:12.2.0.1.0]
Steps to Reproduce
- Upgrade from Pega Marketing 7.22 to Pega Marketing 8.3
- Create a campaign and start it
- Stop the campaign and restart the campaign
Root Cause
A defect in Pegasystems’ code or rules.
Restarting a campaign run fails when the system is configured to use a subject class which has a differently named class key property and column.
Resolution
Apply HFix-57821.
Published January 13, 2020 - Updated December 2, 2021
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