Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Campaign rules don't work, offer not appearing in navigation

SA-2194

Summary



You observe the campaign offer is not displaying in the left navigation pane of the interaction.

Error Messages



No error message on the screen.
The Tracer data shows a NullPointer exception in step 7 of the CACheckOffers activity.

Steps to Reproduce

  1. Enable the Campaign offer in the Driver
  2. Create the Campaign rule
  3. Place the intent when in the criteria to show the offer in left navigation.
  4. The interaction satisfies the configuration but the left navigation does not display the offer.

Root Cause



The root cause of this problem is the SuggestedOffers intent task is not configured in the application.

Resolution



Create a SuggestedOffers intent task for the interaction.

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us