Support Article
Campaign rules don't work, offer not appearing in navigation
SA-2194
Summary
You observe the campaign offer is not displaying in the left navigation pane of the interaction.
Error Messages
No error message on the screen.
The Tracer data shows a NullPointer exception in step 7 of the CACheckOffers activity.
Steps to Reproduce
- Enable the Campaign offer in the Driver
- Create the Campaign rule
- Place the intent when in the criteria to show the offer in left navigation.
- The interaction satisfies the configuration but the left navigation does not display the offer.
Root Cause
The root cause of this problem is the SuggestedOffers intent task is not configured in the application.
Resolution
Create a SuggestedOffers intent task for the interaction.
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.