Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Campaign test runs get stuck in running state

SA-19319

Summary



Campaign test runs intermittently become stuck in a running state.

Error Messages



Not Applicable

Steps to Reproduce



1. Create a campaign.
2. Configure the Plan and save the record.
3. Now configure Audience, Strategy, Engagement, and Volume Constraint and save the record again.
4. Go to Test tab. Click Distribution Test. Use Volume Constraint when prompted and click submit.
5. Do not refresh screen for 5 minutes.
6. After about 5 minutes, refresh the campaign and observe state.


Root Cause

As part of initiating the test run, the engine attempts to lock the cover Campaign work object. In certain scenarios, the Campaign object is not unlocked which prevents the test run from going to resolved. 



Resolution



This issue is resolved in a future release of Pega.

 

Published February 9, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us