Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

"Cancel" button in Reopen screen not behave correctly

SA-32170

Summary



When user click "reopen" link to reopen a closed case, and then user click "Cancel" button. User expected that it will cancel the reopen action.

However, Pega just cancels the UI, but the "Reopen" assignment still there.

User requires advise on how to implement a "Cancel" button which can cancel the whole reopen action.

That is, after user click "Cancel", the case status still "Resolved-Status".


Error Messages



Not applicable


Steps to Reproduce



When user click "reopen" link to reopen a closed case, and then user click "Cancel" button. User expected that it will cancel the reopen action.
However, Pega just cancel the UI, but the "Reopen" assignment still there.


Root Cause



Confirmed from the Product management team, as its an expected behavior, refer to the below explanation.

Resolution



Explanation: When user clicked on the reopen link and then on  Cancel button, it still stays in the reopen assignment in the Out-of-the-box (OOTB) reopen flow.



The flow is messed up at this point since the case is already open, but the available actions are still "Reopen last stage" and "Change stage"."

 

Published January 11, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us