Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Cannot edit delegated strategy rules

SA-5154

Summary



Cannot edit delegated strategy rules

After saving a strategy rule to an unlocked production ruleset and adding that version to My Favorites, when the user opens the rule the only toolbar icon available is the Refresh button.  When the Refresh button is clicked a StringIndexOutOfBoundsException displayed.

 

Error Messages



StringIndexOutOfBoundsException

Steps to Reproduce

  1. Create a strategy rule
  2. Save the strategy rule into an unlocked production ruleset
  3. Add the rule to your favorites
  4. Set the access group of your operator to one that logs into a portal that has access to delegated rules
  5. Log into that portal and open the rule from the delegated rules link
  6. Only button that appears in the toolbar is refresh
  7. Click the refresh button


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.  Due to the response time, there is a timing issue preventing the display of the toolbar icons.

Resolution



This issue is resolved by hotfix item HFix-20553.  This hotfix included an increase in the wait time. 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us