Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Cannot select simulation thread count above 10 in Pega 7.1.7



Thread count cannot be above ten in NBAM when Simulation topology is created. WorkManager maximum thread count in WebSphere was tried to change to 50 and the following parameters were added to prconfig:
     <env name="agent/threadpoolsize" value="20" />
     <env name="services/maxrequestorchildren" value="20" />

Error Messages

Not Applicable

Steps to Reproduce

1. Change the WorkManager maximum threads in Websphere to 50.
2. Add the following to prconfig.xml file:
       <env name="agent/threadpoolsize" value="20" />
       <env name="services/maxrequestorchildren" value="20" />
3. Restart the application. The value could not be set greater than ten from dropdown in the Simulation Topology Settings of Decisioning.

Root Cause

Increasing the thread count functionality for Decisioning: Simulation Settings through prconfig entries was introduced in Pega 7.1.8 release. Hence, the prconfig entries were not reflected in the Simulation Settings page in Pega 7.1.7.


Perform the following local-change:
Add a Dynamic System Setting as:
Ruleset: Pega-Engine
Purpose: prconfig/services/maxrequestorchildren/default
Suggest Edit

Published March 3, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us