Support Article
Cannot view the Test Cases when switching between PegaUnit testi
SA-37368
Summary
Pegaunit Tests created in the Automated Testing landing page in "New version" mode are not visible when swithced to the "old version" mode. It is therefore not possible to schedule the created tests.
How can "New" Pegaunit tests be scheduled in the same way "Old" Automated Unit Tests
Error Messages
Not Applicable
Steps to Reproduce
- Create Unit Test(s)
- Attempt to schedule unit test runs
Root Cause
Pega Unit Testing (New in 7.2.2) and Automated Unit Testing (The “Old version) are separate functionality and not different views of the same thing. As such the new test cases cannot be run using the old scheduler.
Resolution
PegaUnit test cases can be executed using a continuous integration tool (such as Jenkins). The following PDN article explains how this can be figured (using Jenkins as an example).
https://pdn.pega.com/running-all-pegaunit-test-cases-execute-tests-service/running-all-pegaunit-test-cases-execute-tests
Published May 6, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.