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Support Article

Case Match rule does not work when FirstName value is Null

SA-47981

Summary



The Case Match decision rule does not work when value for the FirstName is Null.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a simple case type, Customer.
  2. In this class coupled to the Customer case, create a property 'FirstName' of type Text and optimize this property.
  3. In the case type settings, Track Duplicates, set:
    1. Weighted conditions: 10 for Primary.pyLabel = .pyLabel (weighted conditions is mandatory)
    2. Set 'Case is duplicate when sum >= 10'
    3. Enable 'Configure Must match conditions' and set '.FirstName is same'
  4.  Open the 'Case Match' pyDefaultCaseMatch decision rule coupled to the class of the required case. Include additional Must match conditions such that '.FirstName is not null'
  5. Refresh the settings and confirm the Track duplicates for the Customer case type.
    Note: '.FirstName is not null' is added to the Must match conditions.
  6. In the Customer case, add a simple process which consists of an assignment (Collect Info) and 'Search for duplicates' flow utility. The Collect Info accepts the FirstName through text input.
  7. Launch the Case Worker portal and run the Customer case. Enter the following values for the FirstName in the Collect Info assignment.
  8. Run the tracer to trace the duplicates search flow. Perform this before submitting the Collect Info assignment.
    (Perform this step for the following four cases)
    1. Case 1:

      FirstName = John   SQL : UPPER("PC0"."firstname") = 'JOHN' AND UPPER("PC0"."firstname") IS NOT NULL   Duplicates not found

       
    2. Case 2: 

      FirstName = Robert   Duplicates not found

       
    3. Case 3: 

      FirstName = John  SQL: UPPER("PC0"."firstname") = 'JOHN' AND UPPER("PC0"."firstname") IS NOT NULL  Duplicates found.

       
    4. Case 4: 

      FirstName = <null> (do not enter any value) &nbsp;SQL: UPPER("PC0"."firstname") IS NOT NULL ) &nbsp;Duplicates found. 

Root Cause



A defect in Pegasystems’ code or rules.


Resolution



Apply HFix-38991.


 

Published March 30, 2018 - Updated October 8, 2020

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