Support Article
Case not getting resolved after wait shape completed
SA-36828
Summary
When using Pega Warranty, there is a dependency defined using a wait shape between the Return Material (RM) and Return Authorization (RA) cases.
When the RA case attains the 'Resolved-Completed' status the RM case should get resolved but instead it remains with the status 'New'.
This behavior started to occur after the installation of HFix-33131.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Return Material (RM) case, which will generate a Return Authorization (RA) case in Pega Warranty.
- Resolve the Return Authorization (RA) case.
- Check the status of the RM case, it is showing 'New' instead of 'Resolved-Completed.'
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-33954.
Published May 9, 2017 - Updated October 8, 2020
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