Support Article
Case is not localized to default locale after case completion
SA-57932
Summary
The default Spanish locale is changed to English and a case is completed. After the case is completed, the screen returns to the Case List. However, the case does not switch back to the default Spanish locale after and parts of the screen reflect in English.
Before starting the case:

After case completion:

Error Messages
Not Applicable.
Steps to Reproduce
- Update operator locale to 'es_PR' in Designer Studio
- Log in to the mobile application
- Open a case from the Case List
- Change the locale on selected case to 'en_US' (English) so that the section reloads in English
- Complete the case
- Return to the Case List screen. Parts of the Case List screen are translated to Spanish and others are not
Root Cause
There are custom functions that invoke the pega.clientTools.switchLocale method followed by the pega.u.d.refreshSection API. However, the call to pega.clientTools.switchLocale method is asynchronous.
Resolution
Apply HFix-43715.
Published July 23, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.