Support Article
Case in Review mode when switched between Home and Case
SA-33422
Summary
After launching the intent task in the interaction portal, intent is not displayed in interaction driver.
After switching between the Home and Case tabs, the intent task screen is also not displayed.
This is happening only for some intents which are of one particular class.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a interaction and launch of Intent task from Add task Functionality.
2. Navigate to Home tab and again click on Case tab.
Root Cause
An issue in the custom application code or rules.
The issue is because the custom class in which developer had created the intent tasks does not have inheritance from PegaCA-Work so 'pyAddRecentListItem' datatransform is not getting triggeed.
And the intent tasks of that custom class are not getting displayed in the interaction driver even after launching the intent tasks.
Resolution
Perform the following local-change:
Do the save as of 'pyAddRecentListItem' datatransform of 'PegaCA-Work' in to the custom class, to resolve the issue.
Published February 23, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.