Support Article

Case rule not saving in the highest open RSV

SA-37026

Summary



The changes made to the case rule (specifiying the "allow when" rule in instantiation) via Case Designer are reflected but the corresponding pyDefault rule is not saved-as in the highest open RuleSetVersion.

However, when user clicks on save, it's showing an error pop-up.


Error Messages



** ** in RULE-OBJ-WHEN @BASECLASS HASMESSAGES #20130918T235432.414 GMT: null


Steps to Reproduce




1. Open deal validation Case via Case Designer.
3. Remove the allowed When condition in the instantiation and click Save.
4. Log-off and log-in back.
5. Now observe in which RuleSetVersion the pyDefault rule is.


Root Cause



The issue case is a child case and the parent case is in locked RSV which is causing the issue.

Resolution



Perform the following local-change:

In order to make the changes to the sub-case, the parent case type rule should also be in an unlocked RSV.

When the parent case type rule is saved as to an unlocked RSV explicitly then the issue is solved.

Published April 25, 2017 - Updated May 14, 2017

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