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Support Article

Case search is not working in global search

SA-24022

Summary



Case search is not functioning in global search. When user adds exact object class in the APPLICATION RULE search is working, but the user wants this to be dynamic and not use the hard coded list from each stacked Application "Cases & Data" Tab.

Error Messages



Not Applicable.


Steps to Reproduce



Search any case in global search field in user portal.


Root Cause



Search parameters from out of the box CPM framework did not fully meet the custom requirement.
 

Resolution

User has made the changes in the activity of "CPMSetSearchWorkParams" and set .pzWorkTypes = "All Work Types"(it makes a call to all work types), After this change, user gets search results.

Suggest Edit

Published June 16, 2016 - Updated December 2, 2021

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