Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Case status displays as 'Pending' even after resolving the case

SA-59359

Summary



The user has Smart Investigate (SI) for Payments 7.11 on Pega Platform 7.22.
The case status displays as 'Pending' even after resolving the case.



Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a SWIFT correspondence which has verification True and has post verification status as 'Pending'
  2. Proceed the case so that Corr goes to the verification step
  3. Resolve the case. The correspondence on the case displays as Pending


Root Cause



A defect in Pegasystems’ code or rules.

Existing functionality in SI does not look for Work case status while updating the status if the post generation or post verification status are set. 



Resolution

Perform the following local-change.
  1. Modify the SetPostGenerationStatus and SetPostVerificationStatus activities to add  a When condition
  2. Skip UpdateStatus if Work Case status starts with Resolved or any other custom status according to the requirement






 

Published April 4, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us