Support Article
Case Type does not display on the Next-Best-Action section
Summary
Case Type does not display on the Next-Best-Action section on the Interaction portal. This occurs though the Case Type is set to Show Always using an Intent When condition.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Case Type
- Open the Settings Tab
- Select the Service Request Options
- Select an Intent When condition which is always True from the Suggested Service Requested When
- Select Suggested() from Action
- Create an interaction from the portal. The Case Type does not display on the Next Best Action section
Root Cause
Direct display of Case Types on the Next-Best-Action section on the Interaction portal is not supported. An Intent Task must be created for the Case Type which can be displayed.
Resolution
Perform the following local-change:
- Create an Intent Task (instance of Rule-PegaCA-Intent-Task) for the Case Type and on the Criteria tab
- Select the Intent When as per what the task must display on the Next-Best-Action
To display the Intent Task created on Pega 8.4,
- Launch the App Studio
- Navigate to Settings
- Select General
- Click Suggested Actions
- Select the Enable Deterministic Actions (Intent When) option
Published December 2, 2021
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