Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Case Type does not display on the Next-Best-Action section

KCP-86

Summary

Case Type does not display on the Next-Best-Action section on the Interaction portal. This occurs though the Case Type is set to Show Always using an Intent When condition.

 

Error Messages

Not Applicable

 

Steps to Reproduce

  1. Create a Case Type 
  2. Open the Settings Tab
  3. Select the Service Request Options
  4. Select an Intent When condition which is always True from the Suggested Service Requested When
  5. Select Suggested() from Action
  6. Create an interaction from the portal. The Case Type does not display on the Next Best Action section

 

Root Cause

Direct display of Case Types on the Next-Best-Action section on the Interaction portal is not supported. An Intent Task must be created for the Case Type which can be displayed.

 

Resolution

Perform the following local-change:

  1. Create an Intent Task (instance of Rule-PegaCA-Intent-Task) for the Case Type and on the Criteria tab
  2. Select the Intent When as per what the task must display on the Next-Best-Action

To display the Intent Task created on Pega 8.4,

  1. Launch the App Studio
  2. Navigate to Settings
  3. Select General
  4. Click Suggested Actions
  5. Select the Enable Deterministic Actions (Intent When) option

 

 

 

 

Published December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us