Support Article
Category dropdown does not display all categories
SA-53308
Summary
In Case Manager, reports are managed in the Report browser and the gear icon is clicked to select the Move or Copy option. The rows are manipulated to create duplicate names for different reports.
Additionally, on moving or copying the selected item, the Category dropdown does not display all the categories listed.
Error Messages
Not Applicable
Steps to Reproduce
- Open Reports in the portal.
- Select Move for one report and specify a different category.
- Select the above Category of the report. When using Move for Report Analyze Performance, the category does not display.
- Select a different Category. Repeat the above steps for a different report. Duplicates are created.
Root Cause
A defect in Pegasystems’ code or rules.
A shortcut is not validated if it has has the same label as another shortcut in the same category or not.
Copying a shortcut between categories based on the shortcut rule name is avoided. This is not done based on the report which will be launched because there could be a case where two shortcuts exist in a category that point to the same report but has different parameters on it. Hence, the filters are different on launch.
Resolution
Apply HFix-41287.
Published September 28, 2018 - Updated October 8, 2020
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