Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Channels (Web) Service response spike during release deployment

SA-31414

Summary



The Support Team here have noticed high spikes in response times whenever there is product jar deployment for a Business As usual change in production.

Also to add, these spikes are observed on all nodes which are configured to run the Web services.

 


Error Messages



Not applicable.


Steps to Reproduce



Import rules which include a  change in the Application rule which consists in referencing different ruleset version.
 

Root Cause



This issue was determined to be a product enhancement request FDBK-17676. 

Resolution



Here’s the explanation for the reported behavior:

As the Application rule is changed, the ruleset list is also changed.

The rule resolution cache is associated to a particular ruleset list.

So this has to be rebuilt hence a spike in response time for the time this cache gets rebuilt.

 

 

Published December 17, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us