Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Chart with single record displays incorrect values on Y axis

SA-55727

Summary



In a chart, when displaying a single record with a maximum value of 1, the Y axis values display incorrectly (0's and 1's).


Error Messages



Not Applicable


Steps to Reproduce

  1. Include a chart in a section.
  2. Configure a report definition with two columns of which one is a Count Aggregate function.
  3. Configure the two columns as X and Y axes in the chart.
  4. Set the 'Min value' to 0 and 'Decimals' to 0 in the Y-axis tab of the chart properties. The chart displays only 0's and 1's on the Y-axis when the chart contains only one record with the value 1.





Root Cause



When the chart has one record with the maximum value as 1 to display, it spreads the chart from 0 to 1 and divides the Y-axis into equal divisions with decimals as the Y-axis values (such as, 0.1, 0.2, 0.3). Since the Decimal value is set to zero in the Axis tab of the chart properties, decimal values are eliminated and only 0's and 1's are displayed.


Resolution



Perform the following local-change to display Decimal values on the Y axis: Set the Decimals value to Auto on the Y-axis tab.





 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us