Support Article
Chat Interaction not loading content on browser refresh
SA-84551
Summary
The existing Chat Interaction in the CPM Interaction portal does not load the content when the browser is refreshed.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Interaction portal.
- Initiate a chat.
- Accept the incoming chat.
- Wait for the Chat Interaction to load.
- Refresh the Interaction portal browser.
Root Cause
A defect in Pegasystems’ code or rules.
The dynamic container data model is updated with all the entries in the Parameter page. After a refresh, the displayOnPage GET Request is sent with all the parameters in the Parameter page (data-model). This caused a 400 Bad Request response due to browser URL length limitations.
Resolution
This feature is implemented in Pega Platform 8.1.6, Pega Platform 8.2.3, and Pega Platform 8.3.1.
Published February 15, 2020 - Updated December 2, 2021
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