Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

CheckAvailability on flows break assignment of work to user

SA-15606

Summary



Business logic imposes an SLA on a particular assignment. The "check available" feature relating to an operator is also active. When the assignment is transferred to any operator, the transfer always fails and instead gets rerouted to the workgroup manager. This is true even when the target of the transfer has no vacation scheduled.


Error Messages



Not Applicable.


Steps to Reproduce

Transfer an assignment to an operator.


Root Cause



An issue in the custom application code or rules.  Part of the Application interface during the transfer process establishes a future date which the user selects.  In the background, the Application creates an SLA with goal and deadline times 5 days prior to the selected date. The result is that when the user does not select a date atleast 5 business days in the future, an SLA is created with times in the past.

When the "Check Available" feature is active (tied to the "Unavailable from <> to <>" on the Operator Record), system logic computes that if there is enough time for the would-be assigned operator to complete the task by the deadline, taking into account any unavailable time as noted in the Operator Record.

When a goal date is in the past, then even if the Operator is always available, the operator cannot complete the assignment by the indicated time. The failover logic for an assignment then activates, and the assignment is given to the Workgroup Manager.

Resolution



Perform the following local-change:

Either eliminate the SLA, or change the business logic so that none of the SLA deadlines can be created in the past.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us