Support Article
Checkbox not consistently triggering field visibility
SA-38067
Summary
Checkbox not working as expected.
When users check or uncheck the checkbox field multiple times, it’s not refreshing the sections as expected.
Error Messages
Not Applicable
Steps to Reproduce
First check the checkbox field, then one can see the refresh in section, when user checks and clear multiple times, the section is not refreshing.
Root Cause
Server interactions to show and hide the field are being overridden by further checkbox clicks.
Resolution
Perform the following local-change:
1. In UserWorkForm, add the following:
<script>
function setBusyIndicatorCustom(){
pega.u.d.busyIndInterval = 0;
pega.u.d.setBusyIndicator();
}
function resetBusyIndicatorCustom(){
pega.u.d.busyIndInterval = 2000;
if(pega.u.d.gBusyInd){
pega.u.d.gBusyInd.hide();
}
}
</script>
2: In the action set for the checkbox, bracket the processing actions with script calls for the function.
As the first action on the checkbox, run the script BusyGo. On the final action for the checkbox, run the script BusyStop
3. Adjust timing. If the solution does not work, check the timing of all actions applied to the button.
If necessary, increase the timeout function from 2000 to ensure that the script brackets all actions.
Published June 1, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.