Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Child case stage not refreshed in case manager portal

SA-41555

Summary



User observed that on opening a parent case from pyRecents, the stage displayed for the child case is not refreshed to reflect the correct stage.


Error Messages



Not Applicable


Steps to Reproduce



1. Launch CaseManager 7 portal .
2. Go to items of pyRecents section
3. Move any subcase forward and then click on the same item in pyRecents
4. No refresh takes place


Root Cause



When any work object is opened from pyRecents section, the rule openWorkByHandle is executed. By default, it does not reload the document.So, old data gets populated.

Resolution



Perform the following local-change:

Pass reload flag as true for openWorkByHandle call.

Add below code in UserWorkForm:

openWorkByHandle = function(key, harnessVersion,contentID,dynamicContainerID,skipConflictCheck,reload) {
return pega.desktop.openWorkByHandle(key, harnessVersion,contentID,dynamicContainerID,skipConflictCheck,"true");
}


Note : After these changes doing openWorkByHandle action will reload the page every time.

Suggest Edit

Published August 26, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us