Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Class <blank> does not exist error displays on screen refresh

SA-101521

Summary



Error message displays on refreshing the Search Page on the Pega portal. As a result, the dashboard worklist or workbasket displays incorrectly.


Error Messages



"Class <blank> does not exist" - "NoWorkID"


Steps to Reproduce

  1. Log in to the User portal.
  2. Click the Search link or launch the Calendar.
  3. Perform a search.
  4. Click the browser icon or F5 on the keyboard.


Root Cause



A defect in Pegasystems’ code or rules.
Refresh Section was performed on an incorrect thread. This corrupted the Reload of the screens.



Resolution



Perform the following local-change:

Update the Harness launch from 'Replace Current' to 'New Document'. This creates a new thread and Refresh Section uses the correct thread context.


Published May 30, 2020 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us