Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Clent validation gets fired unnecessarily

SA-2564

Summary



Pega Survey Framework question page is opened in editable form on a modal pop up. IThere is a custom section for adding an attachment. Since, opening a modal popup on top of another modal pop up is not possible, we open the attachment section in pxLocalAction. Client validation fires sporadically when flow action is submitted. It is of note that there is no property on the section that is marked as required.

Error Messages



Please correct the flagged fields before submitting the form!


Steps to Reproduce



1) On a modal pop up, open a survey section in editable form.
2) Include a custom section as an answer to a question. This section calls pxLocalAction where we open the Data-WorkAttach-File section for attachment upload.
3) Try to upload the attachment by submitting the pxLocalAction.

Expected: The flow action should get submitted.

Actual output: Sometimes, it gets submitted while sometimes, we get client validation error message.


Root Cause



pxLocalAction section is being used inside a Modal dialog with a submit button.


Resolution


pxLocalAction section is being used inside a Modal dialog with a submit button. This is wrong configuration and we should not use it there
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us