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Support Article

Click on Add Task does not create a new Service Case

SA-17186

Summary



In a single click on Add Task, does not create a new Service Case in an interaction within the CPM Interaction Portal.

The left panel has the 'Add Task' which shows a menu with the list of service cases. User tries to create any service case by doing a single click (selecting it) and then click on 'Add tasks' button at the bottom of the menu.
It does nothing and just closes the menu. 
Whereas the double click of Service task works fine and the service case is created.


Error Messages

No error message.


Steps to Reproduce

  1. Launch the CPM Interaction Portal.
  2. Create an interaction. 
  3. Click on Add Task. The menu comes in overlay.
  4. Do single click on Intent yask (service case). 
  5. Click on the ‘Add tasks’ button at the bottom of the menu (besides the Cancel button). 


Root Cause



An issue in the custom application code or rules. 

User has customized section rule CPMDisplayTaskInMenu into there ruleset. User did 'Save As' of Out-of-the-box (OOTB) rule from PegaAppCA:07-13-01 which was highest ruleset they did 'Save As'.

In the customized section user is referring to script function onClick_TakeActionItem which is obselete now. The rule CPMDisplayTaskInMenu  is updated now and is in PegaAppCA:07-13-02 rueset. In the updated rule the script function that now being called is queueIntentTask for single click.

Resolution



Perform the following local-change:

Use OOTB
CPMDisplayTaskInMenu rule or do the 'Save As' of latest rule into their ruleset and do customization on top of it.

 

Published January 31, 2016 - Updated December 2, 2021

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