Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Client side interaction failure while using SSO

SA-33037

Summary



When logged in via SSO,Tivoli Access Manager, the client side validations are failing and system behaving inappropriately. 
Following are the ones that we have observed till now.
 

  1. Field level decimal validation added via the "Presentation" tab is not working. Though user is entering decimal value system is still throwing error. 
  2. Field level formatting are not working. Currency fields where $ is getting appended is throwing error. 



Attached Fiddler and in the fiddler we can clearly see that Junk Data " /*<![CDATA[*&nbsp;
document.cookie = "IV_JCT=%2Fwrntymgmttest; path=/"; 
/*]]>*/ " is getting added. 




Error Messages



Not applicable


Steps to Reproduce


 

  1. Login via SSO.
  2. Create a Text Input in your application with Formatting under Presentation Tab -like Currency.
  3. Save and Run the Application.
  4. Edit the data and click outside.



Root Cause



User was using Single Sign-On using standard junction for TAM which was causing the issue.

Resolution



Asked the user to change the configuration to transparent junction from Single Sign-On using standard junction for TAM.
 

Suggest Edit

Published February 4, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us