Support Article
‘Close’ button invisible in operator profile on user portal
SA-22721
Summary
When the operator profile is opened from the user portal, the header color of the operator ID rule instance is light grey, which causes the white ‘Close’ button to be almost invisible. The user is led to believe they are stuck and unable to close the window or return home.
Error Messages
Not applicable
Steps to Reproduce
1. Login to a Pega 7.1 user portal.
2. Click user menu dropdown in Operator profile.
3. Click on 'Profile'. A new popup opens.
4. In that new popup click on the link against 'ID' to open the operator ID. The operator ID opens in the Home tab.
5. Observe that the close icon on the top right of the operator ID window is poorly visible as it is a white button on a light grey background.
Root Cause
The default color for the close circle is the same across portals, so while it is easily visible on the dark grey of the developer portal, it is not easily visible on the lighter background of the user portal.
Resolution
The following CSS will change the color of the 'close circle' and allow for better visibility.
Create stylesheet and add it to the skin
Add the below code in the stylesheet
.pi-close-circle, pi-close-circle::before{
color:grey;
}
Published April 29, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.