Support Article
Close button of NoID does not perform any task
Summary
When there is a stale assignment present, that is, when the assignment has already been processed by user A, and user B tries to open the already processed assignment, the user is shown with the below error.
When the user clicks on "Close" button, no action is performed on click.
Error Messages
"Unable to open an instance using the given inputs: xyz
Contact your system administrator to have this assignment repaired." (CLOSE button displayed).
"Close" button is unresponsive.
Steps to Reproduce
1. Open an assignment as User A
2. Open the same assignment as User B
3. Process the assignment as User A
4. Now, user B has stale assignment (as it is already processed by other user) which is still visible on screen. Error message will be displayed.
5. Close button does not navigate away from the screen.
Root Cause
A defect in Pegasystems’ code or rules
The section “NoID” has 2 dynamic layouts with different visibility settings.
The option to ‘Delete’ ‘Repair’ etc is for Developers when they have CanReconcileProblem privilege. This works fine.
However, the second dynamic layout on a NoID section is displayed for end users who have not got this privilege. Hence, they just get a”Close” button displayed. No action is performed when clicked.
Resolution
Open the "Close" button cell properties in Assign- NoID and add another action "Cancel" after "Run Activity" on "Click" event. For example, when the user clicks the close button it will take them to the previous screen.
To make this change available for all the users, perform Save As of this rule into the application ruleset.
This issue has been raised as a product limitation that will be rectified in a future version.
Published August 26, 2017 - Updated October 8, 2020
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