Support Article
Co-Browse does not work after handover from Chat bot to the Chat
SA-76590
Summary
When creating a Chat interaction after handover from Chat bot, Co-Browse does not work.
During a Co-Browse, the user can accept the session; however, the 'Waiting for customer to accept' status displays. Error occurs on clicking the 'Next' and 'Launch' buttons.
Error Messages
If you were looking for information relating to the Pega Co-Browse product, please go here
If you are looking to login to the Co-Browse admin portal, please go here
Steps to Reproduce
- Initiate a Chat bot conversation and a handover to the Live chat.
- Ask for a Co-Browse session.
- Accept the Co-Browse.
Root Cause
In the pegahelper.js, the serverHostUrl was missing. Hence, it defaulted to usefirefly.com URL instead of pointing to the eu.usefirefly.com URL
Resolution
- Apply HFix-51860.
- Regenerate ChatBot.zip.
a. Log in to the Webchatbotadmin portal using the webchatbot admin credentials.
b. Launch the Webchatbotconfiguration portal.
c. Click the Edit icon for the bot that is already configured. In the modal window, the Download Web Chatbot displays.
e. Click the Download Web Chatbot to download the chatbot zip file.
f. Extract to view the files which include pegahelper.js.
g. In the Chatbot User pages (the HTML page(s) where the bot conversation is started), these files already include the pegahelper.js as a ‘script’ tag with the ‘src’ pointing to the location of these files.
h. Replace the fresh file in that location such that the user bot page loads the latest file.
i. Clear the browser cache.
j. Refresh or reopen the user page and start the use case.
Published April 4, 2019 - Updated December 2, 2021
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