Support Article
Committed hotfixes showing as uncommitted
Summary
Committed hotfixes show as uncommitted.
When user checks the hotfix counts, it is inconsistent before and after hotfix application.
Error Messages
Not Applicable
Steps to Reproduce
1. Click "commit all", the list of uncommitted hotfixes remains unchanged.
2. Install a hotfix, and the numbers of uncommitted and committed hotfixes may change drastically.
Root Cause
A defect or configuration issue in the operating environment.
The next unique ID counter in this environment has been updated to start at 100000 instead of 1.
As a result the next unique ID for hot fixes will be like this HOTFIXORDER-100000. From this query see that the pyUniqueID column is being truncated as HOTFIXORDER-xxxxxx is too large for the column:
SELECT PYPRODUCTID, PYPARENTPRODUCTID, pystatus, PYUNIQUEID, pxinsname FROM pr_data_products
Resolution
Make the following change to the operating environment:
1. Enlarge the pyUniqueID column, that is, ALTER TABLE PR_DATA_PRODUCTS MODIFY pyUniqueID VARCHAR2(32).
2. Update the existing rows to have the correct value for the pyUniqueID column in the pr_data_products table.
The column pxinsname actually has the correct string so just need to set pyUniqueID to be the value of pxInsName.
a. To get a list of what rows that need to be updated:
SELECT pxinsname, pyuniqueid FROM PR_DATA_PRODUCTS WHERE pxinsname != PYUNIQUEID
b. For each row from “a” set pyuniqueid = pxinsname.
c. Once confirmed the changes updated the rows from “a” (and only “a”) correctly, commit them to database.
3. Then retry “commit all” of the hot fixes and the commit will be successful.
Published March 17, 2017 - Updated October 8, 2020
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