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Support Article

Comms manager ABENDed twice - users cannot access production

SA-5196

Summary



Users are unable to login to system and administrator notices ZAS3 transaction ABENDed with AEXZ twice today.

10:24:26 first time.
- Pegasytem shutdown and restarted. Users able to login.

12:31:53 second time
- Pegasystem shutdown and restarted. Then restart errors.

3 PM (approximate)
- Region restarted and PSUP. System looks OK at this time.

Error Messages



TTZ3WPZ3 44527 12:31:53.190 YERABRT ZPDDBCN : AN ERROR HAS OCCURRED. PLEASE CHECK SYSTEM EVENTS.
TTZ3WPZ3 44527 12:31:53.190 YERSDMP >>>> ERROR TRAPPED IN SYSTEM:
TTZ3WPZ3 44527 12:31:53.190 YERSDMP ==> DISPLAYING STATUS MESSAGES (SYSTEM EVENTS, ABORTS) LOGGED SINCE SIGNON:
TTZ3WPZ3 44527 12:31:53.190 YERSDMP PLEASE NOTE TIME STAMPS
TTZ3WPZ3 44527 12:31:53.190 YERSDMP 12:31:53.190 YERABRT ABORT MESSAGE.
TTZ3WPZ3 44527 12:31:53.190 YERSDMP ZPDDBCN : AN ERROR HAS OCCURRED. PLEASE CHECK SYSTEM EVENTS.
TTZ3WPZ3 44527 12:31:53.190 YERSDMP 12:31:53.167 YERSYEV: SEVERE / YERSLOG
TTZ3WPZ3 44527 12:31:53.190 YERSDMP >>>> ABEND AEXZ TRAPPED IN SYSTEM:
TTZ3WPZ3 44527 12:31:53.190 YERSDMP ==> PL/I CONDITION CODE: 9050
TTZ3WPZ3 44527 12:31:53.190 YERSDMP CICS TASK NUMBER 0044527
TTZ3WPZ3 44527 12:31:53.190 YERSDMP FURTHER INFORMATION MAY BE AVAILABLE IN THE CPLI QUEUE
TTZ3WPZ3 44527 12:31:53.190 YERSDMP


Steps to Reproduce



Unknown


Root Cause



The root cause of this problem is defect/misconfiguration in the CICS operating environment. An APAR (PI25180) was identified which addressed an error which was not handled correctly within CICS/ZOS.



Resolution



Customer was unwilling to install the APAR as it would affect many other applications and requested a change to the Communications Manager. As an alternative, configuration was provided to specify that a specific user ID would be rejected WITHOUT the error that resulted in the AEXZ ABEND.

After installing the patch, configure the GCONST with the name of the problematic userID:

  PSON
  GOTO/Z

  GFLM/A/GCONST/ZCX_TCPIP_TERMID_BLOCK

And provide the ID: CICSPROD and type APPR in ACTION


Restart the Communcations Manager by restarting the Pegasystem and any attempts with user ID CICSPROD will result in a message in the log and blocked login.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

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