Support Article
Communicatepro returns 104: "Invalid message type: '{0}'" error
SA-31379
Summary
User is on PRPC 6.1 SP2 and are using Connect HTTP for integration with a SMS message service provider named Communicate pro.
The SMS message service provider fails to identify URL sent in the HTTP message from Pega and always returns the following error message:
104: "Invalid message type: '{0}'"
However, they are able to receive the correct message from Communicate pro when they try running the same URL (as sent by Pega in HTTP message) directly in a browser.
Error Messages
104: "Invalid message type: '{0}'"
Steps to Reproduce
- Create a Connect HTTP rule and configure the properties with values needed for Communicate pro integration.
- Send the HTTP message from Pega to Communicate pro SMS message service provider.
- Communicate pro is always found to return error code 104: "Invalid message type: '{0}'" for HTTP messages sent by Pega.
Root Cause
An issue in the custom application code or rules is identified as root cause of the issue.
HTTP message sent from Pega was not encoded in the format expected by Communicate pro to return the SMS message.
Resolution
Perform the following local-change:
- Update HTTP version from 1.0 to 1.1 in Service tab of Connect HTTP rule form.
- Set Content-Type as “application/x-www-form-urlencoded” in Header fields of Request tab in Connect HTTP rule form.
Published December 15, 2016 - Updated October 8, 2020
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