Support Article
Composite not refreshing upon launching intents
SA-64937
Summary
Certain tabs defined in the Composites are configured to display only for the Interaction case and specific intents.
However, launching an intent displays the tabs (which must not display).
Error Messages
Not Applicable
Steps to Reproduce
- In the Composite, configure a tab, TEST TAB (visible from the Interaction and visible only for a specific intent, INTENT A).
- Create an Interaction.
- Navigate to the interaction driver. TEST TAB is visible.
- Launch an intent, INTENT B. The TEST TAB is visible for INTENT B.
Root Cause
A defect or configuration issue in the operating environment.
The When rule was referenced as PRIMARY.WhenRuleName. However, the When rule was not found as pyWorkPage was not the primary page. pyWorkPage.WhenRuleName must be used instead.
Resolution
Here's the explanation for the resported behavior:
Composites section runs in the D_Interaction context.

D_Interaction is of type PegaCA-Work-Interaction. Hence, the When rule does not run on pyWorkPage. The pyWorkPage must be specified explicitly.
According to Customer Service design, Composites are designed to contain the same data throughout the interaction. The data does not change based on the Service case.
Published October 7, 2018 - Updated December 2, 2021
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