Support Article

Connect-HTTP Not Functioning after Upgrade to 7.2.2

SA-38911

Summary



Additional encoding as part of Connect-HTTP Rule in version Pega 7.2.2 is modifying content sent as query parameters to external systems.

This is causing the connector to fail functionally post upgrade tp Pega 7.2.2.

Error Messages



Not Applicable


Steps to Reproduce

  1. Create a Connect-HTTP rule and pass in the query parameter in both Pega 7.2 and 7.2.2 versions.
  2. Observe the different encoding with special characters and "+".


Root Cause



Additional encoding in Pega 7.2.2 is causing the issue to the user.

Resolution



Apply HFix-34808 to resolve the issue.

Published June 3, 2017 - Updated July 21, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.