Support Article
Connect-HTTP rule does not work properly in one of the env
SA-12371
Summary
User reported that they were seeing error while calling Connect-HTTP rule to create cases. In which one of the property named BankAcctnum is not being set
.
Error in the logs:
AccountInquiryResponse.ResponseContext.ErrorMessage(1).ErrorCode : RSIVAL9000
AccountSearchResponse.ResponseContext.ErrorMessage(1).ErrorCode : RSISUC0000
Error Messages
<RSIResponse Version="7.1" xmlns="http:/customer.name.com/model"><ResponseContext><ErrorMessage ErrorCode="RSIVAL9000">Field 'AccountIdentifier.BankNumber' is required but not present.</ErrorMessage></ResponseContext></RSIResponse>
Steps to Reproduce
Call Connect-HTTP rule.
Root Cause
The root cause of this problem is defect/misconfiguration in the operating environment.
Their connect-http rule is not working properly after upgrade. From our screen share we found that it is not happening on all the nodes, it is specific to few nodes.
Resolution
This issue is resolved by restarting all the nodes. Verified in all nodes.
Published November 6, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.