Support Article
Connect SOAP fails with to "WS-Security"
SA-233
Summary
When running an activity which invokes a Connect SOAP Rule that has a Username Configuration Type WS-Security profile, the SOAP service fails with errors in the log.
Error Messages
com.pega.pegarules.pub.services.RemoteApplicationException: SOAP service failed
at
.............
Caused by:
com.pega.apache.axis2.AxisFault:
Internal Error.
Domain name: <DOMAIN NAME>
Process type: Multiprotocol
Gateway Name: <GATEWAY NAME>
Error message: Rejected by policy.
Stack trace:
Rejected by policy. while processing service <SERVICE> and rule <RULE NAME>-policy_rule_error.
Service error code is 0x00d30003. Transaction Id is XXXX.
Service error header is HTTP/1.1 500 Internal Server Error
Content-Type: text/xml; charset="utf-8"
X-Backside-Transport: FAIL FAIL
Connection: close
Steps to Reproduce
Enable WS-Security for the Connect SOAP Rule then run the activity to invoke the Connect SOAP Rule.
Root Cause
The root cause of this problem is a configuration error.
Resolution
There use the following local-change: Enable the WS-Addressing option in the Connect SOAP rule so Pega will process the routing information and include it in the SOAP header.
Published March 10, 2016 - Updated October 8, 2020
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