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Support Article

Connection failure between Pega and SFDC

SA-34104

Summary



When using the Pega Process Extender application for SalesForce the Pega login is not completing properly.

Error Messages



fail cannot be null. page: OrgDivision. Details: Invalid value for aSource passed to com.pega.pegarules.data.internal.clipboard.ClipboardPageImpl.replace(ClipboardPage) [UserName] H89C88FE521A55FA151BFE727352ADDC6 PegaRULES 7.10 ML7 (coreAssemblyCached_717_644)

info Connection failed. Try again Unauthenticated or not available No ID available Unknown


Steps to Reproduce



Not Applicable


Root Cause



The Pega Process Extender application for Sales Force by default send the users SFDC user id as the pyUserIdentifier parameter in the initial request to PRPC. The OTB IACAuthentication activity processing will first check to see if an existing Data-Admin-Operator-ID record can be found.

If the record can not be found then the activity processing attempts to build the Data-Admin-Operator-ID record for the user using a model record stored in an organization unit record.

The error occurred because the passed in pyUserIdentifier parameter did not match an existing Data-Admin-Operator-ID record nor was there passed in Organization, Division, Unit parameters.

Resolution



Define a user record within PRPC by creating a Data-Admin-Operator-ID record with a user Id that matched the user's SFDC user id.

Published March 9, 2017 - Updated October 8, 2020

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