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Support Article

Connection to http://demo.pegaezicore.com causing latencies

SA-21309

Summary



CPM / CSi application try to connect to the Social Integration (http://demo.pegaezicore.com) server.
The external server is not reachable from the application and this is causing the application to hang until the connection timeout.
As long as Social Analytics services are not required the User want to turn off this feature to avoid any connection.


Error Messages



2016-03-10 16:18:43,471 [l-threads-458833508)] [ STANDARD] [ ] [ MyInsCoCPMI:07.13] ( internal.mgmt.Executable) ERROR - Exception
com.pega.pegarules.pub.services.ConnectorException: Caught unhandled exception: com.pega.apache.http.conn.HttpHostConnectException: Connection to http://demo.pegaezicore.com refused
at com.pegarules.generated.activity.ra_action_pyinvokerestconnector_eb7dafe6dac00116b03b951c8add1e9a.step12_circum0(ra_action_pyinvokerestconnector_eb7dafe6dac00116b03b951c8add1e9a.java:2913)
at com.pegarules.generated.activity.ra_action_pyinvokerestconnector_eb7dafe6dac00116b03b951c8add1e9a.perform(ra_action_pyinvokerestconnector_eb7dafe6dac00116b03b951c8add1e9a.java:260)
...
at com.pegarules.generated.activity.ra_action_cpmprocessthreadeddocuments_28e9248125e0fbd39740f6efb1a3d683.perform(ra_action_cpmprocessthreadeddocuments_28e9248125e0fbd39740f6efb1a3d683.java:62)
...
at com.pega.pegarules.session.internal.async.AgentQueue.run(AgentQueue.java:792)
at com.pega.pegarules.session.internal.async.Agent.runAgentTask(Agent.java:936)


Steps to Reproduce



Launch the CPM portal and watch the logs

Root Cause



From the exception message and the stack trace this is caused by the CPMI Agent “Process Threaded Documents” which is scheduled to run each 30 seconds:
This Agent is used for integration with social media sites.

Resolution



Assuming the Agent is not required at this time, it can be disabled using SMA Agent Management page.
This will remove the exceptions from the log file.
For more details on the CPM Social Engagement features please refer to the following PDN document:
https://pdn.pega.com/documents/customer-process-manager-cpm-713-social-engagement-implementation-guide
The Agent can be enabled at a later time when the relate related functionality is required.

Published March 25, 2016 - Updated December 2, 2021

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