Support Article
ConnectionWaitTimeoutException in WebsphereApplicationServer
SA-11733
Summary
ConnectionWaitTimeoutException in WebsphereApplicationServer.
Error Messages
2014-09-25 05:00:18,116 [ WebContainer : 0] [ Developer] [ GPICTU:01.01.01] (ternal.assembly.FUAManagerImpl) ERROR your_url|A35617DZWGUYC7D your_operator - Database error trying to add rule reference for "Embed-Rule-PegaApp-Financial-Txn"
com.pega.pegarules.pub.database.ConnectionException: Database-General Problem encountered when getting connection for database pegarules 0 Connection not available, Timed out waiting for 179993
From: (unknown)
Caused by SQL Problems.
Problem #1, SQLState null, Error code 0: com.ibm.websphere.ce.cm.ConnectionWaitTimeoutException: Connection not available, Timed out waiting for 179993
at com.pega.pegarules.data.internal.access.ExceptionInformation.createExceptionDueToDBFailure(ExceptionInformation.java:157)
at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnection(ConnectionManagerImpl.java:1265)
at com.pega
Steps to Reproduce
There is no specific use case to reproduce this behavior.
Root Cause
Connectionispool is exhausted due to high number of requestors, when processing messages through activity.
Resolution
1. Apply HFix-6570. This hotfix adds a hook in DatabaseManagementAPI.DatabaseDetails that cleans up stale connections before reporting connections to SMA
2. Increase PegaRULES Datasource max connection pool size to 200.
3. Add JVM Argument -DdisablePK54589=true
4. Change Unused Timeout to 600 seconds and Aged Timeout to 660 seconds in connection pool settings
5. Update Stored Procedure SPPR_SYS_RESERVEQUEUEITEM_B and indexes
6. Update webSphereDefaultIsolationLevel value to 2 in custom properties
Published November 18, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.